Videos YouTube en WordPress

Este tema responde a la consulta de uno de nuestros lectores y como poner un video de YouTube en tu Blog WordPress, desde luego usando WP-SWFObject.

Primero que nada lo que necesitamos es tener instalado wp-swfobject, el plugin para insertar Flash en tu WordPress, luego entramos a www.youtube.com y buscamos en video que deseamos incluir en nuestro blog.

youtube.gif

Una vez ubicado el video que deseamos, si nos fijamos en la parte derecha de la pantalla se tiene About This Video.

youtube1.gif

En esta parte se muestran mas datos de video, entre ellos el campo Embed que contiene el código para insertar el video en cualquier página, el código es de la forma:

  1. <object width="425" height="350">
  2.   <param name="movie"
  3.  value="http://www.youtube.com/v/8C7SxYzDNZk"></param>
  4.   <embed src="http://www.youtube.com/v/8C7SxYzDNZk"
  5.  type="application/x-shockwave-flash"
  6.  width="425" height="350"></embed>

De esto código es muy claro cual es la url del video y el ancho y el alto del mismo, con esto ya podemos insertar el video en nuestro blog, para ello usamos la sintaxis del wp-swfobject con lo cual se tendría para insertar el video:

[CODE]

Cargando Flash

[/CODE]

Con lo cual tendríamos el resultado que se muestra a continuación y como se darán cuenta todo con menos de una línea, desde luego ya evitando el problema de ActiveX con IE.

Cargando Flash

Comentarios Total 41 comentarios


Dei
Publicado: 25/08/2006 1:51 am

Estoy tratando de seguir tus pasos pero no lo logro, bajo el wp-swfobject y hay no se que hacer,porfa explicame como si fuera un bobito.

unijimpe
Publicado: 25/08/2006 3:01 am

Hola, parece que no sabes como instalar el wp-swfobject, para una guia detallada puedes visitar http://unijimpe.pandela.net/?p=18.
Saludos

40-on
Publicado: 25/08/2006 2:48 pm

Para wp existe un plugin (wpvideo) que sirve para youtube y para más, podeis verlo en: http://www.skarcha.com/wp-plugins/wpvideo/

Saludos

anon
Publicado: 28/08/2006 4:24 pm

el problema es que si pones el video asi, la gente que lee el blog via rss no vera el video, porque seguramente no tienen el swobject instalado en sus lectores rss. Eso pasa al menos con netvibes.

unijimpe
Publicado: 06/09/2006 3:56 pm

Buen punto el tema del RSS que no lo habia pensado, vamos a ver una solución para este tema. Gracias por la observación.

unijimpe
Publicado: 06/09/2006 4:03 pm

Para los que recien conocen wp-swfobject, he creado un pagina especial con toda la documentación reunidad y ordenada en: http://unijimpe.pandela.net/?page_id=14

Luis Rull
Publicado: 08/09/2006 9:52 am

Entonces, ¿tengo que copiar a mano

“[SWF]http://www.youtube.com/v/8C7SxYzDNZk, 425, 350[/SWF]”

?

unijimpe
Publicado: 08/09/2006 2:35 pm

Exactamente si tienes un blog en wordpress, tienes que ubicar la url del video que deseas colocar y luego insertar el código “[SWF]http://www.youtube.com/v/8C7SxYzDNZk, 425, 350[/SWF]” cuando estas redactando tu post.

pantuflas
Publicado: 29/11/2006 7:07 pm

he hecho lo que me han dicho pero aun asi sigue percistiendo mi problema ubique la url del embedded, y coloque el codigo correspondiente en mi blog pero nada sigue apareciendo el mensaje:

This movie requires Flash Player 8

ya no se que hacer….. me quiero puro matar…..jajaj. ocupo WordPress 2.0.4. por favor necesito realmente ayuda…jajaj me muero… gracias

pantuflas
Publicado: 29/11/2006 7:40 pm

ademas se el internet explore en su parte inferior de drecha me tira el siguiente me avisa con un simbolo amarillo con signo de exclamacion error en la pagina,, este error dice lo siguiente

Linea: 94
Caracter: 106
Error Se esperaba: ‘/’
Codigo: 0
Direccion URL: http://midireccion/wordpress/?p=9&preview=true

sera por esto que quizas no me funciona correctamente el WP-SwfObject

unijimpe
Publicado: 30/11/2006 1:27 am

A ver, mira instala y activa el plugin de wp-swfobject, luego en tu post escribes: [swf]http://www.youtube.com/v/8C7SxYzDNZk, 425, 350[/swf] tal cual en minúsculas para que pruebes si funciona, ojo que tienes que tener en cuenta las altas y bajas en el texto.

pantuflas
Publicado: 30/11/2006 3:33 am

mmmm me doy por vencido, he hecho tos los pasos que me has indicado pero aun ocurre lo mismo, por ello me rindo con wp-objectswf, probe sin esto copiando todo el codigo que me entrega youtube y me funciono asi, lastima poruqe esperaba poder ocupar el plugin que ud recomendaban.

= mis agradecimientos por la atencion y la ayuda.

pantuflas
Publicado: 11/12/2006 3:40 am

hey porfin lo hice funcionar, :), el error que habia cometido fue que lo subi a la carpeta de plugin con la carpeta sin extraerlo de ahi, si que menso soy…jajajja.

pero mi pregunta es la siguiente por hay algun parametro extra en este plugin ademas del tamaño que se le asigan a la pelicula, me encantaria poder tener un parametro como para el el color de fondo o dejarlo transparente, por que si uno tiene un blog con un fondo de color asignarle el video atraves del plugin queda una huincha blanca que desentona feamente.

lo segundo es cuando llamo un video a traves del swfobject la pelicula queda centrada distinto a como lo hiciera con los codigos . y eso habeses tambien a veces daña la etstructura visual en un post, en el caso que no desees centrarlo.

disculpa la molestia, por tanto preguntar.

unijimpe
Publicado: 11/12/2006 8:52 am

Hola, para el tema del fondo, en el panel de administración en Options > WP-SWFObject puedes configurar el color de fondo que es lo que necesitas o si no agregarle transparencia. Para el segundo punto te puedo enviar una versión modificada para que no este centrada si lo deseas.

pantuflas
Publicado: 11/12/2006 2:45 pm

uyy te lo agradeceria un monton, que pudieses enviarme una version modificada con el punto de la no centralizacion y eso.

bueno te cuento por si mas adelante te interesa, estoy creando un nuevo reproductor para escuchar musica en wordpress, te lo menciono por si te interesa contar con el para que lo testees una ves que ya lo tenga mas o menos finalizado, el motivo principal de hacer este nuevo reproductor es en base al dewmultiplayer ya que este toca las multiplecanciones solo presionando el boton siguiente, la idea es crear uno que sea de rotacion consecutiva o continua, ademas de poder con un php o un xml que almacene la lista de canciones para no incluir tanto codigo en el post cuando se inscruta en el caso del dewmultiplayer.

espero que te entusiasme esto y pueda hacer un aporte a ti como a los usuarios d e tu blog.

unijimpe
Publicado: 11/12/2006 10:15 pm

Hola ya te envié el archivo modificado para que no centre por defecto el flash, respecto al player que estas haciendo me gustaría mucho probarlo asi que cuando quieras te puedo ayudar.
Saludos

abel
Publicado: 20/03/2007 10:11 am

ayundenme quiero sver como se póne cometrios en videos de youtubeeeee

unijimpe
Publicado: 20/03/2007 9:45 pm

Hola Abel, para que coloque comentarios en los vídeos de Youtube, tienes que registrarte en: http://www.youtube.com/signup luego de ello puedes poner tus comentarios a los vídeos que mas te gusten y puedes hacer una lista con los vídeos de tu agrado para que los tengas siempre a la mano.

fizz
Publicado: 13/04/2007 4:14 pm

Holaaa, me funciono de maravilla, gracias y saludos!

stanis
Publicado: 27/04/2007 10:54 am

No consigo, por mucho que lo intento ver los videos que pongo en el blog en el lector rss, ni en vienna, ni en google reader, ni greatnews…

Supongo que es por la forma de insertarlo, pero lo he intentado de todas las formas…, con plugins, insertando el código directamente, etc, etc

¿Alguien que me ayude?

Saludos

Luis
Publicado: 24/05/2007 6:01 pm

No es mucho más sencillo copiar y pegar el código en WP. Yo uso WP hace años y nunca necesité de ningún plugin. Este tipo de plugines nos complican la visualización desde agregadores y además, nos atan a su utilización de por vida. Ni hablar si queremos exportar la información hacia otro CMS.

unijimpe
Publicado: 24/05/2007 7:29 pm

Respecto al tema de compatibilidad con los agregadores, WP-SWFObject es compatible con ellos pues en el Feed genera tags que son compatibles con cualquier lector de fees. Ahora la necesidad de usar este plugin es para insertar flash para prevenir el problema de EOLA’S en internet explorer.

azuka
Publicado: 27/06/2007 4:37 am

Hola, hoy instalé el plugin en mi web. Pero me dice que requiere flash 8. Por qué?

Agradecería mucho su ayuda.

Saludos y éxitos! ^^

unijimpe
Publicado: 27/06/2007 5:32 am

Seguramente tienes un problema de instalación, comúnmente pasa que subes la carpeta que descomprimieron cuando deben subir solo los archivos de la carpeta. Si de dices cual es la ruta de tu sitio te puedo ayudar.

steider
Publicado: 11/07/2007 9:06 pm

porque cuando descargo un vido de you tube y despues de transformarlo a cualquier formato el video es de mala calidad , no se ve nitido como lo como muestran en youtube .nesecito respuestas porfavor.

[-_-] JORGE
Publicado: 13/07/2007 1:31 am

Gracias unijimpe (que raro tu nick)
sigui palabra a palabra el prceso pero ya en el blog me aparecia este mensaje “This movie requires Flash Player 8″que raro, si tengo el 9, puede que el mac no pesque eso (igual lo probé en FIREFOX 2 y SAFARI 3).

El tema es que al final puse el codigo NORMAL

y ahora se ve normal, espero creer que tenia algo que ver el plugin que recomendaste.

Saludos desde el Valle de Aconcagua

unijimpe
Publicado: 15/07/2007 7:53 am

Hola, vi tu blog y he verificado que tienes instalado WP-SWFObject, pero hay un detalle que no tienes el archivo swfobject.js, este archivo debe estar en la carpeta de plugins, en tu caso debe estar en:
http://www.graficmedia.cl/wordpress/wp-content/plugins/swfobject.js

Colocalo y veras que funciona correctamente.

disakia
Publicado: 01/10/2007 3:26 pm

http://www.disakia.com/

buenas he seguido tus pasos, todo funciona ok, me puedes decir por que me genera esas 2// que se ven, te muestro el codigo que genera

//
gracias

Pablo
Publicado: 27/10/2007 11:26 am

Hay una forma muy fácil para insertar vídeos de YouTube en el Blog. Sólo se escribe:
YOUTUBE(CODIGO_DEL_VIDEO)

Sirve en los Blogs creados en Foro.ec.

Más info:
http://foro.ec/2007/10/11/videos-de-youtube-en-tu-blog/

Juancho
Publicado: 29/10/2007 12:47 pm

He visto en varios blogs que suben videos de youtube y todos estan en un solo reproductor, como se puede hacer esto, he intentado subir el url de mi playlist de youtube creyendo que asi se subia toda la lista, pero no funciona. Megustaría que me lo expliquen por favor!

Raul
Publicado: 27/11/2007 12:48 am

Hola!

al igual que algunos usuarios de aquí, yo tambien tengo problema con el flash. Me arroja el siguiente emnsaje de error:
This movie requires Flash Player 8

Tengo instalado todo tal cual se aconseja. ¿¿lo raro de esto?? que sí puedo ver otros videos pero uno me arroja ese mensaje…

¿¿¿qué puede ser??? el video lo puedo ver sin problemas desde youtube o copiando el enlace directamente en la barra.

Saludos y gracias

unijimpe
Publicado: 27/11/2007 11:45 pm

Hola Raul, el problema es que has colocado mal la ruta del vídeo que deseas incluir. Tu has puesto:

<span style="color: #006600; font-weight: bold"></span> http://www.youtube.com/v/lFpFs4Xm0Lk&rel=1&border=0 <span></span>

Cuando debes colocar:
http://www.youtube.com/v/lFpFs4Xm0Lk&rel=1&border=0

Esto seguramente por que lo has insertado en vista de diseño en tu blog. Quita los span sobrantes y veras que funciona bien.

Raul
Publicado: 28/11/2007 8:05 pm

Ah sí, muchas gracias. Tendré presente ese punto de ingresar los enlaces directamente al código y no en vista diseño.

Gracias!

Tone
Publicado: 07/12/2007 1:16 am

genial el plug! muy buen aporte.
sólo saber si hay una versión que no centre el swf wn el post o alguna forma de insertarle algún parámetro para alinearlo a “piacere”.
gracias!!!

derleth
Publicado: 10/03/2008 2:22 pm

jejeje al comienzo tuve los tipicos problemas de todos pero leendo bien el manual ya consegui mi objetivo siiiiiii :D


[…] ejemplo, un clip sobre como embeber un vídeo de YouTube en WordPress. Este no es un ejemplo perfecto, pues WordPress 2.5 lo hace un tanto obsoleto, pero un artículo […]

dif
Publicado: 24/03/2009 11:18 pm

no es mas facil copiar el embed de youtube y pegarlo en “html” al hacer el tema?

afarras
Publicado: 14/07/2009 4:14 am

Al editar un nuevo post utilizando el WP-SWFObject e incluuyendo un video, se me ve bien en la pagina del post, però en la pagina donde salen los posts recientes (resumidos, muchas veces la pàgina de inicio) no se me visualiza el video, y en su lugar se puede leer lo siguiente:

This movie requires Flash Player 9

swfobject.embedSWF(”http://www.youtube.com/v/8C7SxYzDNZk&rel=0&showsearch=0&showinfo=0&iv_load_policy=3″, “swf75721″, “425″, “350″, “9.0.0″, “”, {}, {wmode: “window”, menu: “false”, quality: “high”, bgcolor: “#FFFFFF”}, {});

Alguna idea?

Gracias

Yosterkote
Publicado: 06/08/2009 3:32 am

¡Increíble! Muchas gracias por la información, sin duda muy útil y sencilla.

jugena
Publicado: 11/08/2009 12:21 pm

Hola,

al igual que afarras, me pasa lo mismo.
implemento perfectamente el flash en el post, pero al mirar en los ‘resúmenes’ (post recientes, seleccionados por tags, etc), me aparece lo mismo.
he estado investigando y nada de nada

un saludo

jabi

unijimpe
Publicado: 11/08/2009 7:44 pm

Lo que sucede es que cuando se muestra solo un resumen del post o excerpt, se eliminan las tags script, pero lo que contienen. Es decir el codigo devuelto esta cortado por ello no funciona. Para resolver eso en mi blog modifique el plugin para que no se muestre en el home, categorias y buscador. Habria que hacer un update para configurar donde se permite mostrar flash y donde no se permite. Esta opcion vendra en la siguiente version del plugin.

 

Comentar

En este blog los comentarios están moderados, serán mostrados cuando el administrador los apruebe. Por favor, evita comentarios ofensivos u obscenos por que no serán aprobados.
Si deseas publicar código fuente debes hacerlo entre las etiquedas <code> y </code>, además debes reemplazar los carácteres < por &lt; y > por &gt;.

(Requerido)

(Requerido, no será publicado)

(Requerido)

(Tags aceptados: <a> <em> <strong> <code> <ul> <li>)